using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\wá-ú])\s(?=(¿|¡)[A-ZÃ-Ú])";
string substitution = @"$1. ";
string input = @"Cemré ¿Quién era?";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}