const regex = /([\wá-ú])\s(?=(¿|¡)[A-ZÃ-Ú])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\wá-ú])\\s(?=(¿|¡)[A-ZÃ-Ú])', 'gm')
const str = `Cemré ¿Quién era?`;
const subst = `$1. `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);