re = /([\wá-ú])\s(?=(¿|¡)[A-ZÃ-Ú])/m
str = 'Cemré ¿Quién era?'
subst = '$1. '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result