const regex = /^\/(\*\*-+\*\*)\\$(.*?)^\\\1\/$|./smg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/(\\*\\*-+\\*\\*)\\\\$(.*?)^\\\\\\1\\\/$|.', 'smg')
const str = `/**--------------------------------------------------------------------------**\\
<summary>FunctionName</summary>
<returns>
Returns 1 on success.
Returns 0 on failure.
</returns>
<remarks>
This function is a function.
</remarks>
\\**--------------------------------------------------------------------------**/
int FunctionName()
{
int X = 1;
if(X == 1)
return 1;
return 0;
}`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);