use strict;
my $str = '/**--------------------------------------------------------------------------**\\
<summary>FunctionName</summary>
<returns>
Returns 1 on success.
Returns 0 on failure.
</returns>
<remarks>
This function is a function.
</remarks>
\\**--------------------------------------------------------------------------**/
int FunctionName()
{
int X = 1;
if(X == 1)
return 1;
return 0;
}';
my $regex = qr/^\/(\*\*-+\*\*)\\$(.*?)^\\\1\/$|./smp;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";