$re = '/^(?:(?:ию[нл]|январ|(?:апре|февра)л|(?:сент|окт|но|дек)[яа]бр)ь|(?:ма|авгу)(?:[рс]?т|й))$/miu';
$str = 'Январь
Февраль
Март
Апрель
Май
Июнь
Июль
Август
Сентябрь
Октябрь
Ноябрь
Декабрь';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);