use strict;
my $str = '[\'Mamie Smith\']
["Screamin\' Jay Hawkins"]';
my $regex = qr/\[(["'])(.*?)\1]/mp;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";