const regex = new RegExp('(?<![^\\s\\n])\\d{3}[./]\\d{3,6}(?:/\\d{3})?(?![^\\s\\n])', 'gm')
const str = `Codes like 123/456
123/3456
123/23456
etc are correct
lorem\\123/456 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}