import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\<strong>)([0-9]+)(?=\\s*<\\/strong>)";
final String string = "There are <strong>54</strong> 12cities\n"
+ "There are <strong>54 wee wee we</sstrong> 12cities\n"
+ "There are <strong>54</stron2g> 12cities\n"
+ "There are <strong>5433d</strong> 12cities\n"
+ "There are <strong>54 </strong> 12cities\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}