const regex = /#(\d+)#\s+(\d{4}-\d{2}-\d{2})T(\d{2}:\d{2}:\d{2})-(\d{2}:\d{2})\s+(\S+)\s+(\S+)\s+(.*)\.* task "(.*)"\s.* "(.*)"\s.*action "(.+)"\s+.*\s+return\s+code\s+(\d+)\./;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#(\\d+)#\\s+(\\d{4}-\\d{2}-\\d{2})T(\\d{2}:\\d{2}:\\d{2})-(\\d{2}:\\d{2})\\s+(\\S+)\\s+(\\S+)\\s+(.*)\\.* task "(.*)"\\s.* "(.*)"\\s.*action "(.+)"\\s+.*\\s+return\\s+code\\s+(\\d+)\\.', '')
const str = `#134# 2015-05-14T21:22:40-04:00 PRODNJ-RPT01 Microsoft-Windows-TaskScheduler Task Scheduler successfully completed task "\\WarmUp Vantage" , instance "{E26D061B-15DD-4F58-B80C-4F11225333DF}" , action "D:\\warmupscrt\\BSAImpersonationIssueFixer.exe" with return code 0.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}