#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^|^[^:]+:\/\/|[^\.]+\.)hello\.net"
Local $sString = "http://hello.net" & @CRLF & _
"https://hello.net" & @CRLF & _
"http://www.hello.net" & @CRLF & _
"https://www.hello.net" & @CRLF & _
"http://domain.hello.net" & @CRLF & _
"https://solutions.hello.net" & @CRLF & _
"hello.net" & @CRLF & _
"www.hello.net" & @CRLF & _
"hello.net.domain.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")