import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|^[^:]+:\\/\\/|[^\\.]+\\.)hello\\.net";
final String string = "http://hello.net\n"
+ "https://hello.net\n"
+ "http://www.hello.net\n"
+ "https://www.hello.net\n"
+ "http://domain.hello.net\n"
+ "https://solutions.hello.net\n"
+ "hello.net\n"
+ "www.hello.net\n"
+ "hello.net.domain.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}