using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)\b([n🇳]|(\/\/)|(\/\|\/)|(\/\\\/)|(\|\\\|))+[îi1ÌĮĪÍÏl]+[gb96][gb96]+(er|a)+s?\b";
string input = @"//igger /|/igger /\/igger |\|igger nigger";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}