package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).+Client\sName:\s(?<name>.+)\s+:\s+Client\sEmail:\s(?<email>.+)\s+:\s+Product\sName`)
var str = `Test School BV Client Name: test : Client Email: test@gmail.com : Product Name: test : Billing Cycle: 12 : Country: CO : Domain: test.com.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}