use strict;
my $str = 'Test School BV Client Name: test : Client Email: test@gmail.com : Product Name: test : Billing Cycle: 12 : Country: CO : Domain: test.com.';
my $regex = qr/.+Client\sName:\s(?<name>.+)\s+:\s+Client\sEmail:\s(?<email>.+)\s+:\s+Product\sName/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}