re = /.+Client\sName:\s(?<name>.+)\s+:\s+Client\sEmail:\s(?<email>.+)\s+:\s+Product\sName/m
str = 'Test School BV Client Name: test : Client Email: test@gmail.com : Product Name: test : Billing Cycle: 12 : Country: CO : Domain: test.com.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end