import Foundation
let pattern = #".+Client\sName:\s(?<name>.+)\s+:\s+Client\sEmail:\s(?<email>.+)\s+:\s+Product\sName"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Test School BV Client Name: test : Client Email: test@gmail.com : Product Name: test : Billing Cycle: 12 : Country: CO : Domain: test.com."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)