$re = '/(<a [^>]+?)>\s+<img src="[^"]+?" alt="([^"]+)"/m';
$str = '<a href="/1.webp" data-fancybox="gallary">
<img src="/1.webp" alt="$img_alt">
</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);