import re
regex = re.compile(r"(?i)(f(.*)?(\s)?o(.*)?(\s)?r(.*)?(\s)?t(.*)?(\s)?n(.*)?(\s)?i(.*)?(\s)?t(.*)?(\s)?e)", flags=re.MULTILINE)
test_str = ("fbjrehfdlkjsfortnitesfdsojfoidsjkclnvklnFortnitebjbsvhfsdulfd\n\n"
"F O R T N I T E\n\n"
"Fgfdg\n"
"Ofdsgfdsg\n"
"Rfsdgfdsgf\n"
"Tdsgfsdgf\n"
"Nsdgfsdgf\n"
"Idsgfsdgfds\n"
"Tfsdgfdgf\n"
"Esgfsgfsd\n\n"
"FOOOOOORRRRRRTTTTTNNNNIIIIITTTTTTEEEEEE\n\n"
"F.O.R.T.N.I.T.E\n\n"
"// In the original string before the regex check, leet speak numbers can be replaced with letters.\n"
"f0rtn1t3\n"
"// After writing the \"comment\" above, I found that it matched \"Fornite\" in it and realized the monster I had created.\n"
"// Please help me.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")