package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^#([0-9A-F]{3}){1,2}$`)
var str = `Only matches when there are 3 & 6 digits
#
#1
#12
#123
#1234
#12345
#123456
#1234567
Only matches if the letters used are: A, B, C, D, E & F
#ABCDEF
#BCDEFG
#0A1B2C
#0E1F2Z
Must use the 'i' flag to match lower & upper case.
#AaBbCc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}