use strict;
my $str = 'Only matches when there are 3 & 6 digits
#
#1
#12
#123
#1234
#12345
#123456
#1234567
Only matches if the letters used are: A, B, C, D, E & F
#ABCDEF
#BCDEFG
#0A1B2C
#0E1F2Z
Must use the \'i\' flag to match lower & upper case.
#AaBbCc';
my $regex = qr/^#([0-9A-F]{3}){1,2}$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}