#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[NUM]\s*(?:hour|minute|time)s?\b|!|\?{2}"
Local $sString = "Is it possible to apply [NUM] times" & @CRLF & _
"Is it possible to apply [NUM] time" & @CRLF & _
"Called [NUM] hour ago" & @CRLF & _
"waited [NUM] hours" & @CRLF & _
"waiting [NUM] minute" & @CRLF & _
"waiting [NUM] minutes???" & @CRLF & _
"Are you kidding me !" & @CRLF & _
"Waiting?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")