#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[(code|php)\]([\s\S]+?)\[\/\1\]"
Local $sString = "[code]here is some code[/code]" & @CRLF & _
"[php]here is some other code[/php]" & @CRLF & _
"[code]this is malformed[/php]" & @CRLF & _
"[php]and so is this[/code]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")