import re
regex = re.compile(r"(http:\/\/\s*|https:\/\/\s*|ftp:\/\/\s*)?(www\s*)?(?(1)([.]\s*))?(?(2)([.]\s*))?([a-zA-Z0-9.-]{2,256})(\s*[.]\s*)(ru|pl|kz|by|ua|com|in|pt|br|co.uk)(?![a-zA-Z])([?|#]{1}[=&#a-zA-Z0-9]{2,128})?", flags=re.UNICODE | re.IGNORECASE)
test_str = ("http:// www . alga-deweloper . pl\n"
"TIRA UM: Ńąm iuvaret tus electram. Tempor http://www.google.com in eam, ut dictas disputando vim.\n"
"NO TIRA: kuchnia.Na impedit ne, cu pri vęri nostro, mel ut integre praesent dissentias.\n"
"TIRA UM: Ceteros inćorruptę google.com?sad=asd id, saępe ńullam vix ut.\n"
"TIRA UM: Eam ut ępićurei adólesćens. Nam ąd sumo agąm. Vis te dicam https://www.google.com.\n"
"TIRA UM: Has ęa, ei cóngue tęmpóribus comprehęnsam http://asdasd asdas da www.amazon.co.uk.\n"
"NÃ TIRA: No nónumy doćtus sd.asd.comia uma pizza.nan asjJ.domain djJ.co asd.uk, altęra cónśetetur ut.\n"
"SECRETO: Hinc expetenda ocurreret at has. Ex eum ętiam http:// asdasdasd . com Cu vix.\n"
"SECRETO: Hinc expetenda ocurreret at has. Ex eum ętiam www . asdasdasd . com Cu vix.\n"
"SECRETO: http:// www . alga-deweloper . pl sdsdfsdfsdf\n"
"NÃ TIRA: Altęra cónśetetur ut ?asd=asdd asdasd sdfsdfsdfsdf.\n"
"TIRA UM: Ceteros inćorruptę http://www.google6.com#sdfsdf id, saępe ńullam vix ut.\n"
"TIRA UM: Ceteros inćorruptę http://www.google6.com?asdads=asd&asasd=sdasd#sdfsdf id, ńullam vix ut.\n"
"TIRA UM: Altęra cónśetetur www.donet.come sdffd. domain . com asdasd\n"
"TIRA UM: Altęra cónśetetur www.donet.come sdffd. www . aasd . com asdasd\n"
"TIRA UM: http:// www . alga-deweloper . pl")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")