import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = ##"(http:\/\/\s*|https:\/\/\s*|ftp:\/\/\s*)?(www\s*)?(?(1)([.]\s*))?(?(2)([.]\s*))?([a-zA-Z0-9.-]{2,256})(\s*[.]\s*)(ru|pl|kz|by|ua|com|in|pt|br|co.uk)(?![a-zA-Z])([?|#]{1}[=&#a-zA-Z0-9]{2,128})?"##
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = ##"""
http:// www . alga-deweloper . pl
TIRA UM: Ńąm iuvaret tus electram. Tempor http://www.google.com in eam, ut dictas disputando vim.
NO TIRA: kuchnia.Na impedit ne, cu pri vęri nostro, mel ut integre praesent dissentias.
TIRA UM: Ceteros inćorruptę google.com?sad=asd id, saępe ńullam vix ut.
TIRA UM: Eam ut ępićurei adólesćens. Nam ąd sumo agąm. Vis te dicam https://www.google.com.
TIRA UM: Has ęa, ei cóngue tęmpóribus comprehęnsam http://asdasd asdas da www.amazon.co.uk.
NÃ TIRA: No nónumy doćtus sd.asd.comia uma pizza.nan asjJ.domain djJ.co asd.uk, altęra cónśetetur ut.
SECRETO: Hinc expetenda ocurreret at has. Ex eum ętiam http:// asdasdasd . com Cu vix.
SECRETO: Hinc expetenda ocurreret at has. Ex eum ętiam www . asdasdasd . com Cu vix.
SECRETO: http:// www . alga-deweloper . pl sdsdfsdfsdf
NÃ TIRA: Altęra cónśetetur ut ?asd=asdd asdasd sdfsdfsdfsdf.
TIRA UM: Ceteros inćorruptę http://www.google6.com#sdfsdf id, saępe ńullam vix ut.
TIRA UM: Ceteros inćorruptę http://www.google6.com?asdads=asd&asasd=sdasd#sdfsdf id, ńullam vix ut.
TIRA UM: Altęra cónśetetur www.donet.come sdffd. domain . com asdasd
TIRA UM: Altęra cónśetetur www.donet.come sdffd. www . aasd . com asdasd
TIRA UM: http:// www . alga-deweloper . pl
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)