using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\[|\G(?!^))('[^\\']*(?:\\.[^\\']*)*')\s*,?\s*(?=[^\]]*?\])";
string input = @"['F\'oo', 'B\'ar']
eq('Property', ['F\'oo', 'Ba\'r', '123'])";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}