re = /cpe:2\.3:[aho](?::(?:[a-zA-Z0-9!"#$%&'()*+,\\\-_.\/;<=>?@\[\]^`{|}~]|\\:)+){10}$/m
str = 'cpe:2.3:a:1024cms:1024_cms:1.4.1:*:*:*:*:*:*:*
cpe:2.3:a:alawar:motor_town\\:_machine_soul_free:1.1:*:*:*:*:android:*:*
cpe:2.3:a:lemonldap-ng:lemonldap\\:\\::0.6:*:*:*:*:*:*:*
cpe:2.3:a::::::::::
cpe:2.3:a:vendor:product:version:update:edition:lang:sw_edition:target_sw:target_hw:other:bla:bla:bla:bla:bla'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end