import Foundation
let pattern = ##"cpe:2\.3:[aho](?::(?:[a-zA-Z0-9!"#$%&'()*+,\\\-_.\/;<=>?@\[\]^`{|}~]|\\:)+){10}$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
cpe:2.3:a:1024cms:1024_cms:1.4.1:*:*:*:*:*:*:*
cpe:2.3:a:alawar:motor_town\:_machine_soul_free:1.1:*:*:*:*:android:*:*
cpe:2.3:a:lemonldap-ng:lemonldap\:\::0.6:*:*:*:*:*:*:*
cpe:2.3:a::::::::::
cpe:2.3:a:vendor:product:version:update:edition:lang:sw_edition:target_sw:target_hw:other:bla:bla:bla:bla:bla
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)