# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/('\w+'\s*).*?(?=[,\]])/$1/g;t' <<< "['name' {d763e18f-1719-480b-bcd6-8fea7bad894e} Parameter, 'class' {8471633e-4a54-4c86-bd2b-56d58baf2fbb} Parameter, 'id' {23471633e-4a54-4c86-bd2b-56d58baf2fbb} Parameter]"