const regex = /('\w+'\s*).*?(?=[,\]])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\'\\w+\'\\s*).*?(?=[,\\]])', 'g')
const str = `['name' {d763e18f-1719-480b-bcd6-8fea7bad894e} Parameter, 'class' {8471633e-4a54-4c86-bd2b-56d58baf2fbb} Parameter, 'id' {23471633e-4a54-4c86-bd2b-56d58baf2fbb} Parameter]`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);