#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "Bon(.+?)r"
Local $sString = "BonjourBonjour"
Local $sSubst = "\n# $&:\n\t"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)