package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Bon(.+?)r`)
var str = `BonjourBonjour`
var substitution = "\n# $&:\n\t"
fmt.Println(re.ReplaceAllString(str, substitution))
}