use strict;
my $str = 'BonjourBonjour';
my $regex = qr/Bon(.+?)r/p;
my $subst = '\\n# $&:\\n\\t';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";