import re
regex = re.compile(r"Bon(.+?)r")
test_str = "BonjourBonjour"
subst = "\\n# $&:\\n\\t"
result = regex.sub(subst, test_str)
if result:
print(result)