import Foundation
let pattern = #"Bon(.+?)r"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"BonjourBonjour"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"\n# $&:\n\t"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)