re = /([^\.]\s[A-Z][a-z]+)/m
str = 'CACA mou et Pipi dans ta Bouche sale con de Juif.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end