using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)(?!.*?start)^(\w+)\s(\w+)\s(\w+)(?=.*?end)";
string input = @"abcd 123 123
start
abcd 123 123
abcd 123 123
abcd 123 123
end
abcd 123 123";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}