# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^https:\\/\\/(?:www\.)?(?:youtube(?:-nocookie)?\.com\\/(?:watch\?v=|embed\\/)|youtu\.be\\/)([\w-]+)(?:\?.+)?$/$1/gm;t' <<< "Tested in 2024 with various share/embed methods on YouTube video
https://youtu.be/Lg9vg9c01n4?si=eNXa2974pilScfAE
https://www.youtube.com/watch?v=Lg9vg9c01n4
https://www.youtube.com/embed/Lg9vg9c01n4?si=1QX6Cz4e5eoHpi26
https://www.youtube-nocookie.com/embed/Lg9vg9c01n4?si=1QX6Cz4e5eoHpi26
"