#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^https:\/\/(?:www\.)?(?:youtube(?:-nocookie)?\.com\/(?:watch\?v=|embed\/)|youtu\.be\/)([\w-]+)(?:\?.+)?$"
Local $sString = "Tested in 2024 with various share/embed methods on YouTube video" & @CRLF & _
"" & @CRLF & _
"https://youtu.be/Lg9vg9c01n4?si=eNXa2974pilScfAE" & @CRLF & _
"https://www.youtube.com/watch?v=Lg9vg9c01n4" & @CRLF & _
"https://www.youtube.com/embed/Lg9vg9c01n4?si=1QX6Cz4e5eoHpi26" & @CRLF & _
"https://www.youtube-nocookie.com/embed/Lg9vg9c01n4?si=1QX6Cz4e5eoHpi26" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)