const regex = /^https:\/\/(?:www\.)?(?:youtube(?:-nocookie)?\.com\/(?:watch\?v=|embed\/)|youtu\.be\/)([\w-]+)(?:\?.+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https:\\\/\\\/(?:www\\.)?(?:youtube(?:-nocookie)?\\.com\\\/(?:watch\\?v=|embed\\\/)|youtu\\.be\\\/)([\\w-]+)(?:\\?.+)?$', 'gm')
const str = `Tested in 2024 with various share/embed methods on YouTube video
https://youtu.be/Lg9vg9c01n4?si=eNXa2974pilScfAE
https://www.youtube.com/watch?v=Lg9vg9c01n4
https://www.youtube.com/embed/Lg9vg9c01n4?si=1QX6Cz4e5eoHpi26
https://www.youtube-nocookie.com/embed/Lg9vg9c01n4?si=1QX6Cz4e5eoHpi26
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);