// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^https:\/\/(?:www\.)?(?:youtube(?:-nocookie)?\.com\/(?:watch\?v=|embed\/)|youtu\.be\/)([\w-]+)(?:\?.+)?$").unwrap();
let string = "Tested in 2024 with various share/embed methods on YouTube video
https://youtu.be/Lg9vg9c01n4?si=eNXa2974pilScfAE
https://www.youtube.com/watch?v=Lg9vg9c01n4
https://www.youtube.com/embed/Lg9vg9c01n4?si=1QX6Cz4e5eoHpi26
https://www.youtube-nocookie.com/embed/Lg9vg9c01n4?si=1QX6Cz4e5eoHpi26
";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}