using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"259(38|46|80|92|9[6-9])";
string input = @"25997";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}