$re = '/259(38|46|80|92|9[6-9])/';
$str = '25997';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);