package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?si)\b[johny]+\b\s+\b[aplsed]+\b`)
var str = `The myth of Johnny Appleseed states that he ate many apple seeds
#misspellings
Johnny Applseed
Johny Appleseed
Johnny Applesee
#Letter case
johnny appleseed
JOHNNY APPLESEED
JoHny ApPleseED`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}