using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"settings\.([\w\.]+)";
string input = @"var serial = new serialport.SerialPort(settings.serial.port, { baudrate : settings.serial.baud, parser: serialport.parsers.readline(""\n"") });
require(""console-stamp"")(console, settings.general.consoleLogDateFormat);";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}