package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`settings\.([\w\.]+)`)
var str = `var serial = new serialport.SerialPort(settings.serial.port, { baudrate : settings.serial.baud, parser: serialport.parsers.readline("\n") });
require("console-stamp")(console, settings.general.consoleLogDateFormat);`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}