re = /settings\.([\w\.]+)/
str = 'var serial = new serialport.SerialPort(settings.serial.port, { baudrate : settings.serial.baud, parser: serialport.parsers.readline("\\n") });
require("console-stamp")(console, settings.general.consoleLogDateFormat);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end