$re = '/(<iframe.*?src=([\"\'])https?:\/\/w{0,3}.?youtube.com.*?(\2).*?\>)(.*?)(\<\/iframe\>)/m';
$str = '<iframe src="http://youtube.com" width="100" height="200">data</iframe>
<iframe src=\'http://youtube.com\' width="100" height="200">data</iframe>
<iframe width="100" src=\'http://youtube.com\' width="100"></iframe>
<iframe src="https://youtube.com" width="100" height="200">data</iframe>
<iframe src=\'https://youtube.com\' width="100" height="200">data</iframe>
<iframe width="100" src=\'https://youtube.com" width="100">data</iframe>
<iframe width="560" height="315" src="https://www.youtube.com/embed/tvrXet3Lx4U" frameborder="0" allowfullscreen></iframe>
<iframe width="560" height="315" src="https://www.youtube.com/embed/tvrXet3Lx4U" frameborder="0" allowfullscreen>data</iframe>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);