package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z]{3}[0-9]{2}$`)
var str = `asd23
asd23
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}