# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b[a-zA-Z]{1,2}\d{3,5}[a-zA-Z]?\b//gm;t' <<< "M394
,MP4245)
TD493!
X4958A
V49534@
U394U
A5909.
TED492
R32
R4!3
U394UU
A5909AA
5349A"